MobilePay are having issues at the moment
Incident Report for Bambora Online
Resolved
This incident has been resolved.
Posted 2 months ago. May 08, 2019 - 21:13 CEST
Update
We still experience issues with MobilePay and investigations are still ongoing.
Posted 2 months ago. May 08, 2019 - 17:05 CEST
Investigating
MobilePay are currently observing service degradation on the following MobilePay services:

- MobilePay Subscriptions (fully down)
- MobilePay Finland (fully down)
- MobilePay Box (fully down)
- MobilePay MyShop (significant impact)
- MobilePay Online (limited impact)
- MobilePay PoS (limited impact)
- MobilePay Support Tool (prolonged response times)
- MobilePay Invoice (fully down)
- MobilePay Portal (fully down)

Next update within an hour (5PM CET)
Posted 2 months ago. May 08, 2019 - 16:09 CEST
This incident affected: ePay, Bambora Checkout and 3rd Party Services (MobilePay Online).