Ongoing login issue on the Merchant UI portal
Incident Report for Bambora Online
Resolved
We have monitored the results and the Merchant UI portal is now stable again.

We apologies for any inconvenience this may have caused
Posted Dec 01, 2021 - 14:51 CET
Monitoring
A fix has been implemented and logging onto the Merchant UI portal (merchant.bambora.com) seems stable again.

We'll be monitoring the results of the fix.

We apologies for the inconvenience this may have caused
Posted Dec 01, 2021 - 13:35 CET
Investigating
We are currently experiencing some issues logging onto the Merchant UI portal (merchant.bambora.com)

We are investigating this issue with high priority and will send you an update as soon as we have more news.

Thank you for your understanding.
Posted Dec 01, 2021 - 12:55 CET
This incident affected: Bambora Online PSP (Bambora Checkout).