Issues with iDeal
Incident Report for Bambora Online
Resolved
The iDeal issue on ePay platform has been resolved, and new iDeal payments can be made through the paymentwindow again.
Posted May 01, 2020 - 16:08 CEST
Investigating
We are currently experiencing issues with iDeal on the ePay platform. No new iDeal payments can be made through the paymentwindow.

We are investigating the issue right now.
Posted May 01, 2020 - 11:24 CEST
This incident affected: 3rd Party Services (iDeal).