Service disruption on: Visa/Dankort
Incident Report for Bambora Online
Resolved
We are seeing that the 3D Secure authentications with Visa/Dancard are back to a normal level.
Posted May 18, 2021 - 13:33 CEST
Monitoring
We would like to inform you about an ongoing issue with 3DS authentication on Visa/Dancard as of 09:16 on 2021-05-18

We have contacted the party involved and will update you as soon as more information becomes available.

Thank you for your patience and understanding.
Posted May 18, 2021 - 11:11 CEST
This incident affected: Bambora Online Acquirers (Nets/Teller).