Acquiring settlements - Delayed EUR settlements.
Incident Report for Bambora
Resolved
This incident has been resolved.
Posted Oct 31, 2023 - 10:10 CET
Identified
We would like to inform you about technical issues with a service provider affecting settlements scheduled for the 2023-10-30 in EUR currency. Due to this, the funds associated with the transactions concerned will be credited to customers bank accounts with a 1-day delay.

We are working together with our service provider to resolve this matter with the highest priority. We will update you as soon as more information becomes available.

We are sorry for the inconvenience that this may cause.
Posted Oct 30, 2023 - 15:22 CET
This incident affected: Bambora Acquiring (Settlement).