Delayed settlements and reports for Bambora Acquiring transactions

Incident Report for Worldline

Resolved

This incident has been resolved.
Posted Jun 03, 2026 - 08:06 CEST

Monitoring

We would like to inform you about third party delays affecting settlements scheduled for the 2026-06-02.

As a result, the funds and reports related to the affected transactions for certain merchants will be credited to your account with a delay.

The issue has been resolved and we apologize for the inconvenience.
Posted Jun 02, 2026 - 11:01 CEST
This incident affected: Worldline Acquiring (Settlement, Reports).