Problems with Evry
Incident Report for Bambora
Resolved
This incident has been resolved.
Posted Sep 29, 2022 - 19:00 CEST
Investigating
We are currently investigating this issue.
Posted Sep 29, 2022 - 17:16 CEST
This incident affected: Bambora Online PSP (Bambora Classic (ePay)).