Degraded performance on ePay administration
Incident Report for Bambora Online
Resolved
This incident has been resolved.
Posted Oct 15, 2020 - 17:54 CEST
Update
The issue is still being investigated
Posted Oct 15, 2020 - 15:53 CEST
Investigating
We are currently seeing some issues displaying the transactions in the ePay administration.

The issue is being investigated
Posted Oct 15, 2020 - 10:38 CEST
This incident affected: ePay.