Delayed settlements for Bambora Acquiring transactions
Incident Report for Bambora Online
Resolved
We have been closely monitoring since corrective actions were taken to resolve the issue and have observed no additional impacts. 

Due to technical issues settlements scheduled for the 1st of June were delayed. The funds associated with the transactions concerned were credited later in the afternoon on the 1st of June for the majority of our customers.

We are apologise any inconvenience this may have cause.
Posted Jun 02, 2021 - 09:43 CEST
Monitoring
Please be informed that the funds associated with the transactions concerned previously reported to be delayed by 1 day delay will, for a majority of our customers, be credited in the afternoon of June 1.

We will continue to monitor the remaining transactions to be credited.

We apologise for any inconvenience caused.
Posted Jun 01, 2021 - 16:28 CEST
Investigating
We want to inform you about technical issues affecting settlements scheduled for the 1st of June.
Due to this, the funds associated with the transactions concerned will be credited to your account with a 1 day delay.
Our technical teams are working to resolve this matter with the highest priority. We will update you as soon as more information becomes available.
We are sorry for the inconvenience that this may cause.
Posted Jun 01, 2021 - 10:09 CEST