Service disruption on: Fraud Fighter
Incident Report for Bambora Online
Resolved
Our technical teams have identified the cause of this disruption and the problem has been resolved.
We apologize for any inconvenience.
Posted Feb 21, 2022 - 15:44 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 21, 2022 - 14:11 CET
Investigating
We are currently experiencing a service disruption that is affecting Fraud Fighter.
The issue is being investigated as a matter of urgency and the service will be fully restored at the earliest possible opportunity.

Updates will be provided as soon as additional information becomes available.
Posted Feb 21, 2022 - 13:36 CET
This incident affected: Bambora Online PSP (Bambora Classic (ePay)).