Bambora Checkout Merchant UI Issues
Incident Report for Bambora Online
Resolved
This incident has been resolved.
Posted Oct 30, 2020 - 21:04 CET
Investigating
We are currently experiencing some delays in data synchronization to the Merchant UI (merchant.bambora.com). This means that there will be a delay of up to 1-1½ hours before new transactions are visible in the UI.

This does not affect processing of new transactions, only when they can be viewed in the Merchant UI.
Posted Oct 30, 2020 - 11:23 CET
This incident affected: Bambora Checkout.