Delayed settlements for Bambora Acquiring transactions for USD and EUR.

Incident Report for Worldline

Resolved

We are pleased to inform you that the issue has now been successfully resolved.

The settlements originally scheduled for 2025-10-29 have been resent today, 2025-11-06.

We apologies for any inconvenience this may have caused.
Posted Nov 06, 2025 - 13:41 CET

Investigating

We would like to inform you of a technical issue affecting a small number of USD and EUR settlements scheduled for 2025-10-29.

The matter is currently under urgent investigation.

We apologize for any inconvenience this may cause.
Posted Nov 04, 2025 - 15:31 CET
This incident affected: Worldline Acquiring (Settlement).