Bambora Checkout Merchant UI Issues
Incident Report for Bambora
Resolved
We are no longer seeing a data synchronization to the Merchant UI (merchant.bambora.com).

Again, we apologize for the inconvenience
Posted May 06, 2021 - 14:14 CEST
Identified
We are currently experiencing some delays in data synchronization to the Merchant UI (merchant.bambora.com) for some merchants. This means that there will be a delay of approximately 4-5 hours before new transactions are visible in the UI.

This does not affect the processing of new transactions, only when they can be viewed in the Merchant UI.

We apologize for the inconvenience
Posted May 06, 2021 - 10:24 CEST
This incident affected: Bambora Online PSP (Bambora Checkout).