Ongoing service interruption with Mobile Terminals

Incident Report for Worldline

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 13:29 CET

Update

Please be informed that due to a technical issue with an external mobile connectivity provider, your may have experienced disruptions when performing transactions with your mobile terminal between 05:00 and 10:00 CET today.

We confirm that as of 09:05 CET, normal service has been resumed and you will be able to perform transactions again.

We apologise for any inconvenience caused.
Posted Mar 20, 2025 - 13:28 CET

Investigating

We would like to inform you about an ongoing issue with an external mobile connectivity provider.

Due to this you may experience connectivity disruptions on your mobile terminal.

We have contacted the party involved and will update you as soon as more information becomes available.

Thank you for your patience and understanding.
Posted Mar 20, 2025 - 07:03 CET
This incident affected: Worldline Instore PSP (Mobile terminal connectivity).