Service disruption on terminals

Incident Report for Worldline

Resolved

We’ve found the issue and an update has been implemented. Please perform a daily settlement and the terminal will work.
Posted Nov 08, 2025 - 16:58 CET

Investigating

We are currently investigating an issue with our terminals and updating our status page continuously with information.
Posted Nov 08, 2025 - 16:21 CET
This incident affected: Worldline Instore PSP (Worldline Instore).