Bambora Checkout Merchant UI Issues
Incident Report for Bambora Online
Resolved
This incident has been resolved.
Posted Dec 31, 2020 - 08:32 CET
Identified
We are currently experiencing some delays in data synchronization to the Merchant UI (merchant.bambora.com) for some merchants. This means that there will be a delay of 45 minutes to 1 hour before new transactions are visible in the UI.

This does not affect processing of new transactions, only when they can be viewed in the Merchant UI.
Posted Dec 30, 2020 - 10:33 CET
This incident affected: Bambora Online PSP (Bambora Checkout).