Bambora Checkout Merchant UI Issues
Incident Report for Bambora Online
Resolved
This incident has been resolved.
Posted Apr 15, 2021 - 19:05 CEST
Identified
We are currently experiencing some delays in data synchronization to the Merchant UI (merchant.bambora.com) for some merchants. This means that there will be a delay before new transactions are visible in the UI.

This does not affect the processing of new transactions, only when they can be viewed in the Merchant UI.

The system is currently catching up
Posted Apr 15, 2021 - 12:02 CEST
This incident affected: Bambora Online PSP (Bambora Checkout).