Sporadic slow/unavailable Paymentwindow
Incident Report for Bambora Online
Resolved
All systems are back to normal.
Posted Mar 11, 2020 - 14:27 CET
Monitoring
The issue have been identified and solved. We are now monitoring the systems
Posted Mar 11, 2020 - 14:12 CET
Investigating
We are experiencing a sporadic slow/unavailable Paymentwindow.

This only affect some transactions.

We are investigating
Posted Mar 11, 2020 - 11:44 CET
This incident affected: ePay.