Problems with Evry, Swedbank, Handelsbanken and Elavon payments
Incident Report for Bambora Online
Resolved
This incident has been resolved.
Posted Jan 22, 2021 - 16:26 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 22, 2021 - 16:26 CET
Investigating
We are currently investigating this issue.
Posted Jan 22, 2021 - 15:43 CET
This incident affected: Bambora Online PSP (Bambora Classic (ePay), Bambora Checkout) and Bambora Online Acquirers (EVRY, Swedbank, Handelsbanken, Elavon).