Swish Service Disturbances
Incident Report for Bambora
Resolved
The disturbance at Swedbank is now solved and Swish payments to and from this bank work as normal again.
Posted Mar 25, 2020 - 10:07 CET
Monitoring
At the moment Swish are experiencing disturbances at Swedbank that may affect Swish payments to and from this bank. Swedbank is working to fix the problem and we will send you a new email as soon as the disturbance is solved.
Posted Mar 25, 2020 - 09:30 CET
This incident affected: Bambora Online Additional Payment Methods (Swish).