Please be informed that due to a technical issue with an external mobile connectivity provider, your may have experienced disruptions when performing transactions with your mobile terminal between 2023-03-17 11.40 until 2023-03-21 13:00 CET.
We confirm that as of 2023-03-21 15:40 CET, normal service has been resumed and you will be able to perform transactions again.
We apologise for any inconvenience caused.
Posted Mar 21, 2023 - 15:50 CET
Investigating
We would like to inform you about an ongoing issue with an external mobile connectivity provider as of 11:40 CET on 2023-03-17.
Due to this you may experience connectivity disruptions when performing transactions using our mobile terminals IWL250 GPRS/3G.
We have contacted the party involved and will update you as soon as more information becomes available.
Thank you for your patience and understanding.
Posted Mar 17, 2023 - 12:15 CET
This incident affected: Bambora Instore PSP (Mobile terminal connectivity).