Delayed IC++ Reports
Incident Report for Bambora
Resolved
We want to inform you that the issue of delay in generating IC++ reports has been resolved.
We apologise for any inconvenience caused.
Posted Jul 13, 2022 - 13:58 CEST
Identified
We want to inform you of a delay in generating IC++ reports.
Due to a technical issue, today's reports will not be made available until tomorrow.
We apologise for any inconvenience caused.
Posted Jul 12, 2022 - 15:05 CEST
This incident affected: Bambora Acquiring (Reports).