Service disruption on: Direct Banking as of 12:40 CET today 05-05-2022
Incident Report for Bambora
Resolved
Due to a technical problem, you might have experienced problems performing transactions using the Direct Banking payment method between 12:40 CET and 13:50 CET 05-05-2022.
Posted May 05, 2022 - 14:55 CEST
Investigating
We are currently experiencing a service disruption that is affecting Direct Banking. The issue is being investigated as a matter of urgency and the service will be fully restored at the earliest possible opportunity.

Updates will be provided as soon as additional information becomes available.

We apologize for any inconvenience.
Posted May 05, 2022 - 12:42 CEST
This incident affected: Bambora Online Additional Payment Methods (Direct Banking).