Problems with Evry payments
Incident Report for Bambora Online
Resolved
This incident has been resolved.
Posted 2 months ago. May 14, 2019 - 06:27 CEST
Identified
The disturbance is caused by a planned network maintenance 04:00-06:00 CET.
Posted 2 months ago. May 14, 2019 - 05:17 CEST
Investigating
We are currently investigating this issue.
Posted 2 months ago. May 14, 2019 - 05:01 CEST
This incident affected: ePay.