MobilePay are having issues at the moment
Incident Report for Bambora
Resolved
From MobilePay:
All MobilePay services are still stable and infrastructure causing the impact has been taken out of service. We do not expect further issues.
Posted Jul 24, 2019 - 16:47 CEST
Monitoring
From MobilePay:
UPDATE

All MobilePay services are fully recovered. Logon recovered at 14:21 CEST and all services fully at 14:25 CEST. Investigation is still ongoing but currently the issue is fully circumvented.
Posted Jul 24, 2019 - 14:41 CEST
Investigating
Message from MobilePay:
We are experiencing errors with logon to MobilePay in Denmark and Finland since 13:58 CEST. We are investigating.
New status at 15:00 CEST at the latest.
Posted Jul 24, 2019 - 14:26 CEST
This incident affected: Bambora Online Additional Payment Methods (MobilePay Online) and Bambora Online PSP (Bambora Checkout).