A fix has been implemented and we are monitoring the results.
Posted Sep 23, 2025 - 10:40 CEST
Update
We are continuing to work on a fix for this issue.
Posted Sep 23, 2025 - 08:24 CEST
Identified
This incident has been identified and service degradation is not isolated to Essentials 1.
Posted Sep 22, 2025 - 17:04 CEST
Investigating
We would like to inform you about an ongoing issue with an external mobile connectivity provider as of 12:00 CET on 22 September.
Due to this you may experience connectivity disruptions when performing transactions using our mobile terminals in Sweden with Telia network and Essential 1 simcards.
We have contacted the party involved and will update you as soon as more information becomes available.
Thank you for your patience and understanding.
Posted Sep 22, 2025 - 14:59 CEST
This incident affected: Worldline Instore PSP (Mobile terminal connectivity).