Problems with Evry, Swedbank, Handelsbanken and Elavon payments
Incident Report for Bambora Online
Resolved
This incident has been resolved.
Posted Jan 28, 2021 - 13:34 CET
Investigating
We are currently investigating this issue.
Posted Jan 28, 2021 - 13:25 CET
This incident affected: Bambora Online PSP (Bambora Classic (ePay), Bambora Checkout) and Bambora Online Acquirers (EVRY, Swedbank, Handelsbanken, Elavon).