Resolved: Bambora Classic (ePay)
Incident Report for Bambora Online
Resolved
We've monitored the results, and will now mark the incident as resolved.
Posted Mar 10, 2022 - 15:47 CET
Monitoring
Due to a technical problem might have experienced problems performing transactions using the Bambora Classic (ePay).

Our technical teams have identified the cause of this disruption and the problem has been resolved at 14:45 CET.

We apologize for any inconvenience.
Posted Mar 10, 2022 - 14:50 CET
Investigating
We are currently experiencing a service disruption that is affecting Bambora Classic (ePay). The issue is being investigated as a matter of urgency and the service will be fully restored at the earliest possible opportunity.

Updates will be provided as soon as additional information becomes available.

We apologize for any inconvenience.
Posted Mar 10, 2022 - 13:16 CET
This incident affected: Bambora Online PSP (Bambora Classic (ePay)).