Issues with card payments for merchants using Nets or Teller acquiring.
Incident Report for Bambora Online
Resolved
This incident has been resolved.
Posted Feb 14, 2020 - 09:23 CET
Update
The issues has been marked as resolved by the vender.
Posted Feb 14, 2020 - 09:23 CET
Monitoring
Nordic customers may experience issues with card payments, Internet payments and terminal transactions. This is caused by an issue external to Nets.
Posted Feb 14, 2020 - 09:04 CET
This incident affected: Acquirers (Nets/Teller Acquiring).