Delayed Payments on merhant.bambora.com
Incident Report for Bambora
Resolved
Synchronization of payment data to merchant.bambora.com is now back to normal.
Posted Dec 30, 2019 - 19:53 CET
Identified
We are currently experiencing some delays in data synchronization of payments to merchant.bambora.com, which can cause a delay of up to 20 minutes until new payments are visible.

This does not affect payment processing in any way, and is only a delay in payment information on merchant.bambora.com.
Posted Dec 30, 2019 - 16:12 CET
This incident affected: Bambora Online PSP (Bambora Checkout).