Ongoing service interruption with Mobile terminals using Telia simcard (Finland)
Incident Report for Bambora
Resolved
We have been closely monitoring since the corrective action was taken, and have observed no additional impacts. We are considering this issue resolved at this time.

We apologize for the service interruption and we thank you for your patience while our teams worked to restore service.
Posted Nov 18, 2022 - 10:35 CET
Monitoring
We have seen improved connectivity for our devices. We will continue to monitor the services to ensure stability.

We apologise for any inconvenience caused.
Posted Nov 17, 2022 - 16:43 CET
Investigating
We would like to inform you about an ongoing issue with an external mobile connectivity provider in Finland as of 10:30 CET on 2022-11-17.

Due to this you may experience connectivity disruptions when performing transactions using our mobile terminals.

We have contacted the party involved and will update you as soon as more information becomes available.

Thank you for your patience and understanding.
Posted Nov 17, 2022 - 13:21 CET
This incident affected: Bambora Instore PSP (Mobile terminal connectivity).