Service disruption on terminal invoice payments
Incident Report for Worldline
Resolved
This incident has been resolved.
Posted Jan 30, 2025 - 16:49 CET
Investigating
We would like to inform you about an ongoing issue with a 3rd party service for invoice payments.

Due to this you may experience issues with invoice payments in your card terminal.

We have contacted the party involved and will update you as soon as more information becomes available.

Thank you for your patience and understanding.
Posted Jan 30, 2025 - 16:39 CET
This incident affected: Worldline Instore 3rd Party Services (Invoice).