Acquiring settlements - Delayed settlements for some Finnish customers
Incident Report for Worldline
Resolved
We would like to update you on the technical issue that was identified with a partner / payment service provider which affected some of our Finnish customers, causing a delay in the processing of transactions and turn the settlement of those transactions.

The transactions affected by this issue have now been settled.

We apologize for any inconvenience this may have caused.
Posted Sep 20, 2023 - 10:34 CEST
Monitoring
We would like to update you on the technical issue that was identified with a partner / payment service provider which affected some of our Finnish customers, causing a delay in the processing of transactions and turn the settlement of those transactions.

We have received information that the issues have been resolved and we expect to be able to fully process the transactions and settlements by tomorrow 2023-09-20.

We apologize for any inconvenience this may have caused and we will monitor until the processing has been finalized.
Posted Sep 19, 2023 - 15:46 CEST
Investigating
We would like to inform you about an ongoing technical issue with a partner / payment service provider affecting some of our Finnish customers and causing a delay in the processing of transactions and in turn the settlement of the transactions concerned.

Due to this, the funds associated with the transactions concerned will be credited to your account with a delay and settlements will be performed once transactions for the dates concerned have been received by Worldline from the payment service provider.

We are in contact with the parties involved who are investigating the issue with highest priority and we will update you as soon as more information becomes available.

This issue only concerns some of our Finnish customers.

We apologize for any inconvenience this may have caused.
Posted Sep 18, 2023 - 16:53 CEST
This incident affected: Worldline Acquiring (Settlement).