Service disruption on: Mobile terminal connectivity
Incident Report for Bambora
Resolved
Please be informed that due to a technical issue with an external provider for mobile connectivity, you may have experienced connectivity disruptions using your mobile terminal.

We can confirm that normal service has been resumed for mobile terminal connectivity now and you will be able to perform transactions again.

We apologise for any inconvenience caused.
Posted Jun 14, 2021 - 13:46 CEST
Investigating
Bambora is currently experiencing a service disruption related to one of our service providers for mobile terminal connectivity.

We apologise for the disruption. We are currently in contact with our service provider to restore these services.

Updates will be provided as soon as additional information is available.
Posted Jun 14, 2021 - 10:23 CEST
This incident affected: Bambora Instore PSP (Mobile terminal connectivity).