Ongoing display issue in the Merchant Portal
Incident Report for Bambora Online
Resolved
Please be advised that we have experienced display issues in our Merchant Portal (Merchant.bambora.com) today 25-02-2022 between 01:00 and 10:40 CET.

We would like to reassure you that our payment platform was stable and no impact on transaction processing has been identified.

Our technical teams have identified the cause and the problem has been solved.

Please accept our sincere apologies for any resulting inconvenience and rest assured that preventive measures have been taken to avoid future occurrences of this issue.

If you have any further administrative or technical questions, do not hesitate to contact our support
Posted Feb 25, 2022 - 10:43 CET
Investigating
We are currently experiencing some delays in data synchronization to the Merchant Portal (Merchant.bambora.com)

This causes a delay of approximately 7 hours before new transactions are visible in the Merchant Portal.

We would like to reassure you that our payment platform is stable and no impact on transaction processing has been identified at this moment.

We are investigating this issue with high priority and will send you an update as soon as we have more news.

Thank you for your understanding.
Posted Feb 25, 2022 - 08:46 CET
This incident affected: Bambora Online PSP (Bambora Checkout).